Lab 7: Route Redistribution - NetwaxLab

Breaking

Facebook Popup

BANNER 728X90

Friday, January 2, 2015

Lab 7: Route Redistribution


Task

Topology


  1. Configure IP Address as per given in topology.
  2. Configure OSPF Area's as per given in topology and provide router id as per router number (like 1.1.1.1 for R1)and configure OSPF through interface only in Area 20.
  3. Make sure R5 and R6 able to ping R1. (Do possible changes according to you).
  4. Configure EIGRP as per given in topology. Make sure EIGRP AS number is 100.
  5. Enable RIP as per given in topology. Make sure RIP v2 configure.
  6. Basic redistribution between RIP and OSPF. (all subnets will be redistribute)
  7. Basic redistribution between OSPF to EIGRP (all subnets will be redistribute and exclude R6 for Redistribution).
  8. All the Loopback will be manual summarize.

After Completion of this task, verify routes and ping all the routers each other.


Solution


Task 2: Configure OSPF Area's as per given in topology and provide router id as per router number (like 1.1.1.1 for R1) and configure OSPF through interface only in  Area 20.

On R1
=====

router ospf 1
 router-id 1.1.1.1
 network 10.0.12.0 0.0.0.255 area 0
 network 10.0.13.0 0.0.0.255 area 0


On R2
=====

router ospf 1
 router-id 2.2.2.2
 network 10.0.12.0 0.0.0.255 area 0
 network 10.0.24.0 0.0.0.255 area 10


On R3
=====

router ospf 1
 router-id 3.3.3.3
 network 10.0.13.0 0.0.0.255 area 0
 network 10.0.34.0 0.0.0.255 area 10


On R4
=====

router ospf 1
 router-id 4.4.4.4
 network 10.0.24.0 0.0.0.255 area 10
 network 10.0.34.0 0.0.0.255 area 10


On R5
=====

interface Serial0/0
 ip ospf 1 area 20


On R6
=====

interface Serial0/0
 ip ospf 1 area 20


Task 3: Make sure R5 and R6 able to ping R1.(Do possible changes according to you).

On R2
=====

router ospf 1
 area 10 virtual-link 4.4.4.4

On R3
=====

router ospf 1
 area 10 virtual-link 4.4.4.4

On R4
=====

router ospf 1
 area 10 virtual-link 3.3.3.3
 area 10 virtual-link 2.2.2.2


Task 4: Configure Eigrp as per given in topology. Make sure Eigrp AS number is 100.


On R3
=====

router eigrp 100
 network 10.0.37.0 0.0.0.255
 no auto-summary


On R6
=====

router eigrp 100
 network 10.0.67.0 0.0.0.255
 no auto-summary

On R7
=====

router eigrp 100
 network 10.0.37.0 0.0.0.255
 network 10.0.67.0 0.0.0.255
 network 10.0.70.0 0.0.0.255
 network 10.0.71.0 0.0.0.255
 no auto-summary

On R10
======

router eigrp 100
 network 10.0.70.0 0.0.0.255
 network 10.0.110.0 0.0.0.255
 network 10.10.1.0 0.0.0.255
 network 10.10.2.0 0.0.0.255
 network 10.10.3.0 0.0.0.255
 network 10.10.4.0 0.0.0.255
 no auto-summary

On R11
======

router eigrp 100
 network 10.0.71.0 0.0.0.255
 network 10.0.110.0 0.0.0.255
 network 11.11.1.0 0.0.0.255
 network 11.11.2.0 0.0.0.255
 network 11.11.3.0 0.0.0.255
 network 11.11.4.0 0.0.0.255
 no auto-summary

 

Task 5: Enable RIP as per given in topology. Make sure RIP v2 configure.

On R2
======

router rip
 version 2
 network 10.0.0.0
 no auto-summary

On R5
=====

router rip
 version 2
 network 10.0.0.0
 no auto-summary

On R8
=====

router rip
 version 2
 network 10.0.0.0
 no auto-summary

On R9
=====

router rip
 version 2
 network 9.0.0.0
 network 10.0.0.0
 no auto-summary


Task 6: Basic redistribution between RIP and OSPF. (all subnets will be redistribute)

On R2
=====

router ospf 1
 redistribute rip metric 1 subnets

router rip
 redistribute ospf 1 metric 1


On R5
=====

router rip
 redistribute ospf 1 metric 1

router ospf 1
 redistribute rip metric 1 subnets


Task 7: Basic redistribution between OSPF to EIGRP (all subnets will be redistribute and exclude R6 for Redistribution).

On R3
=====

router eigrp 100
 redistribute ospf 1 metric 1 1 1 1 1

router ospf 1
 redistribute eigrp 100 metric 1 subnets

 

Task 8: All the Loopback will be manual summerize.

On R9
=====

interface FastEthernet0/0
 ip summary-address rip 9.9.0.0 255.255.248.0


On R10
======

interface Serial0/0
 ip summary-address eigrp 100 10.10.0.0 255.255.248.0

interface Serial0/1
 ip summary-address eigrp 100 10.10.0.0 255.255.248.0

On R11
======

interface Serial0/0
 ip summary-address eigrp 100 11.11.0.0 255.255.248.0

interface Serial0/1
 ip summary-address eigrp 100 11.11.0.0 255.255.248.0
 

No comments:

Post a Comment