Simple
MPLS Configuration Example
Topology |
R1
hostname R1
ip cef
no ip domain lookup
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface FastEthernet0/0
no sh
ip address 10.0.0.1 255.255.255.0
router eigrp 99
network 1.1.1.0 0.0.0.255
network 10.0.0.0 0.0.0.255
end
R2
hostname R2
interface Loopback0
no sh
ip address 2.2.2.2 255.255.255.255
interface FastEthernet0/0
no sh
ip address 10.0.0.2 255.255.255.0
interface FastEthernet0/1
no sh
ip address 30.0.0.1 255.255.255.0
mpls ip
router eigrp 99
redistribute ospf 1 metric 100 100 100 100 100
network 10.0.0.0 0.0.0.255
router ospf 1
log-adjacency-changes
redistribute eigrp 99 metric 1 subnets
network 2.2.2.0 0.0.0.255 area 0
network 30.0.0.0 0.0.0.255 area 0
end
R3
hostname R3
ip cef
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface FastEthernet0/0
no sh
ip address 30.0.0.2 255.255.255.0
mpls ip
interface FastEthernet0/1
no sh
ip address 40.0.0.1 255.255.255.0
mpls ip
router ospf 1
log-adjacency-changes
network 30.0.0.0 0.0.0.255 area 0
network 40.0.0.0 0.0.0.255 area 0
network 3.3.3.0 0.0.0.255 area 0
end
R4
hostname R4
ip cef
interface Loopback0
ip address 4.4.4.4 255.255.255.255
interface FastEthernet0/0
no sh
ip address 40.0.0.2 255.255.255.0
mpls ip
interface FastEthernet0/1
no sh
ip address 20.0.0.2 255.255.255.0
router eigrp 90
redistribute ospf 1 metric 100 100 100 100 100
network 20.0.0.0 0.0.0.255
auto-summary
router ospf 1
log-adjacency-changes
redistribute eigrp 90 metric 1 subnets
network 40.0.0.0 0.0.0.255 area 0
network 4.4.4.0 0.0.0.255 area 0
end
R5
hostname R5
ip cef
interface Loopback0
ip address 5.5.5.5 255.255.255.255
interface FastEthernet0/0
no sh
ip address 20.0.0.1 255.255.255.0
router eigrp 90
network 5.5.5.5 0.0.0.0
network 20.0.0.0 0.0.0.255
end
----
No comments:
Post a Comment